内容:

实现如下图所示的企业网络规划:S1、S2、R1为局域网内设备,R1为网关; R2、S3为广域网上设备。PC1、PC2连接到S2,FTP Server连接到R1,PC3连接到S3。
主要功能包括:
1.根据网络结构合理规划IP地址;
2.R1和R2间配置为PPP协议,利用CHAP进行认证。
3.S1和R1间使用OSPF协议,配置为Area 1;R1和R2间使用OSPF协议,配置为Area 0;R2和S3间使用OSPF协议,配置为Area 2;
4.在S2上划分VLAN,并通过S1实现PC1与PC2互通;
5.在R1上应用NAT,实现局域网内设备访问广域网的PC3,并实现PC3可访问局域网内FTP Server;
6.配置ACL,实现PC2能Ping通R2接口IP,但不能Ping通PC3


话不多说,上图。

这是我画的图。首先说一下题,

S1是核心交换机,需要开启路由功能,配置好两个VLAN的地址
S2是接入交换机,需要把F0/1这个口换成trunk口通过多个VLAN,f/2和f/3要换成access口。
R1这个路由器,配置NAT要配置静态NAT(也就是内部局域网一个IP对应一个外部地址),注意别把时钟忘了。
R2路由器要配置OSPF;ACL访问控制列表deny掉PC2经过NAT转换后的IP,然后permit any。
S3交换机就只把两端接口用no switchport关掉交换机功能,然后配置IP和路由器一样。还要配置完OSPF。

上答案(可能有错,大部分正确,可能是粘贴时出错了)


基本配置

PC1:192.168.1.2
PC2:192.168.2.2
PC3:192.168.3.2
FTP服务器:192.168.4.2
S1与R1之间网段172.16.1.0
R1与R2之间网段172.16.2.0
R2与S3之间网段172.16.3.0

S1全部配置

Switch>en
 Switch#
 Switch#conf t
 Switch(config)#ip routing//开启路由功能
 Switch(config)#vlan 10
 Switch(config-vlan)#vlan 20
 Switch(config-vlan)#int vlan 10
 Switch(config-if)#ip add 192.168.1.1 255.255.255.0//配置VLAN地址
 Switch(config-if)#no sh
 Switch(config-if)#int vlan 20
 Switch(config-if)#ip add 192.168.2.1 255.255.255.0
 Switch(config-if)#no sh
 Switch(config-if)#int f0/1
 Switch(config-if)#no switchport//关闭交换机功能
 Switch(config-if)#ip add 172.16.1.1 255.255.255.0
 Switch(config-if)#no sh
 Switch(config-if)#exit
 Switch(config)#router ospf 1
 Switch(config-router)#network 172.16.1.0 0.0.0.255 area 1
 Switch(config-router)#network 192.168.1.0 0.0.0.255 area 1
 Switch(config-router)#network 192.168.2.0 0.0.0.255 area 1//配置ospf

S2全部配置(这个最全了)

Switch#conf t
 Switch(config)#vlan 10
 Switch(config-vlan)#vlan 20
 Switch(config-vlan)#int f0/2
 Switch(config-if)#switchport mode access//改成access口(后来发现它默认就是access口,其实不用写)
 Switch(config-if)#no sh
 Switch(config-if)#switchport access vlan 10//划分给VLAN10,此处有坑,VLAN1是默认VLAN,不能拿来用,当天下午就踩坑了,一会儿通一会儿不通的,怪不得书上都VLAN10,用10以后的数字(感觉VLAN2也能用)
 Switch(config-if)#int f0/3
 Switch(config-if)#no sh
 Switch(config-if)#switchport mode access
 Switch(config-if)#switchport access vlan 20
 Switch(config-if)#int f0/1
 Switch(config-if)#no sh
 Switch(config-if)#switchport mode trunk

R1全部配置(整理有点乱)

int f0/0
ip add 172.16.1.2 255.255.255.0
no sh
int s2/0
ip add 172.16.2.1 255.255.255.0
clock rate 64000//时钟不能忘
no sh
int f1/0
ip add 192.168.4.1 255.255.255.0
no sh
//以上配置端口地址
username R2 password samepass
int s2/0
encapsulation ppp
ppp authentication chap
//这段配置PPP使用CHAP完成认证
router ospf 1
network 172.16.1.0 0.0.0.255 area 1
network 192.168.4.0 0.0.0.255 area 1//FTP服务器忘了那可就ping不通了
network 172.16.2.0 0.0.0.255 area 0
//配置OSPF
R1(config)#int s2/0
R1(config-if)#ip nat outside
R1(config-if)#int f0/0
R1(config-if)#ip nat inside
R1(config)#int f1/0
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#ip nat inside source static 192.168.1.2 172.16.2.3
R1(config)#ip nat inside source static 192.168.2.2 172.16.2.4
R1(config)#ip nat inside source static 192.168.4.2 172.16.2.5
//以上配置NAT,只能是静态NAT(看不懂的话,建议看文章最下方链接)

R2全部配置

interface Serial2/0
 ip address 172.16.2.2 255.255.255.0
 interface FastEthernet0/0
 ip address 172.16.3.1 255.255.255.0
username R1 password samepass
 int s2/0
 encapsulation ppp
 ppp authentication chap
 //配置PPP使用CHAP完成认证
 router ospf 1
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 2
 //配置OSPF
//下面配置ACL
 access-list 1 deny 172.16.2.4//这里deny掉的是PC2经过NAT转换后的IP
 access-list 1 permit any
 //下面ACL应用到f0/0接口
int f0/0
 ip access-group 1 out

S3配置(本来想略掉)

步骤:
把两端的端口关掉交换机功能,用no switchport,输入完这个命令,这个核心交换机就跟路由器一样了,然后配置两端ip地址,然后把ospf也配上,完事儿!

int f0/2
no switchport//关掉交换机功能
ip add 172.16.3.2 255.255.255.0
no sh
int f0/1
no switchport
ip add 192.168.3.1 255.255.255.0
no sh
router ospf 1
net 172.16.3.0 0.0.0.255 area 2
net 192.168.3.0 0.0.0.255 area 2//配置OSPF

下面放上我借鉴的链接吧!

链接1:三层交换机的配置
https://blog.51cto.com/13725021/2113295

链接2:NAT的分配(这个可能是难点)。
https://blog.csdn.net/miaomiaojinxin/article/details/101554431

1 个评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注